Requirements

  • NodeJS v8+
  • NPM v4 is recommended. (npm v5 comes with node 8, but has too many bugs as at the time of this writing)
  • Mongodb as default DB. Install and run it
  • Redis for sessions. Install and run it.